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Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License
(GFDL), Version 1.3 or any later version published by the Free Software Foundation with no Invariant Sections, no Front-Cover
Texts, and no Back-Cover Texts. You can find a copy of the GFDL at this link or in the file COPYING-DOCS distributed with
this manual.

This manual is part of a collection of GNOME manuals distributed under the GFDL. If you want to distribute this manual
separately from the collection, you can do so by adding a copy of the license to the manual, as described in section 6 of the
license.

Many of the names used by companies to distinguish their products and services are claimed as trademarks. Where those
names appear in any GNOME documentation, and the members of the GNOME Documentation Project are made aware of those
trademarks, then the names are in capital letters or initial capital letters.

DOCUMENT AND MODIFIED VERSIONS OF THE DOCUMENT ARE PROVIDED UNDER THE TERMS OF THE GNU
FREE DOCUMENTATION LICENSE WITH THE FURTHER UNDERSTANDING THAT:

1. DOCUMENT IS PROVIDED ON AN "AS IS" BASIS, WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED
OR IMPLIED, INCLUDING, WITHOUT LIMITATION, WARRANTIES THAT THE DOCUMENT OR MODIFIED
VERSION OF THE DOCUMENT IS FREE OF DEFECTS MERCHANTABLE, FIT FOR A PARTICULAR PURPOSE
OR NON-INFRINGING. THE ENTIRE RISK AS TO THE QUALITY, ACCURACY, AND PERFORMANCE OF THE
DOCUMENT OR MODIFIED VERSION OF THE DOCUMENT IS WITH YOU. SHOULD ANY DOCUMENT OR
MODIFIED VERSION PROVE DEFECTIVE IN ANY RESPECT, YOU (NOT THE INITIAL WRITER, AUTHOR OR
ANY CONTRIBUTOR) ASSUME THE COST OF ANY NECESSARY SERVICING, REPAIR OR CORRECTION. THIS
DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF ANY DOC-
UMENT OR MODIFIED VERSION OF THE DOCUMENT IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS
DISCLAIMER; AND

2. UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER IN TORT (INCLUDING NEGLI-
GENCE), CONTRACT, OR OTHERWISE, SHALL THE AUTHOR, INITIAL WRITER, ANY CONTRIBUTOR, OR
ANY DISTRIBUTOR OF THE DOCUMENT OR MODIFIED VERSION OF THE DOCUMENT, OR ANY SUPPLIER
OF ANY OF SUCH PARTIES, BE LIABLE TO ANY PERSON FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDEN-
TAL, OR CONSEQUENTIAL DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAM-
AGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY
AND ALL OTHER DAMAGES OR LOSSES ARISING OUT OF OR RELATING TO USE OF THE DOCUMENT AND
MODIFIED VERSIONS OF THE DOCUMENT, EVEN IF SUCH PARTY SHALL HAVE BEEN INFORMED OF THE
POSSIBILITY OF SUCH DAMAGES.

Feedback

To report a bug or make a suggestion regarding the GChemTable application or this manual, go to the GChemTable home page.

ghelp:fdl
http://savannah.nongnu.org/projects/gchemutils


GChemTable manual iii

COLLABORATORS

TITLE :

GChemTable manual

ACTION NAME DATE SIGNATURE

WRITTEN BY Jean Bréfort October 27, 2014

REVISION HISTORY

NUMBER DATE DESCRIPTION NAME

GChemTable Manual
V0.14.0

July 2012 Jean Bréfort jean.brefort@normalesup.org
GNOME Documentation Project

GChemTable Manual
V0.12.0

April 2010 Jean Bréfort jean.brefort@normalesup.org
GNOME Documentation Project

GChemTable Manual
V0.10.0

October 2008 Jean Bréfort jean.brefort@normalesup.org
GNOME Documentation Project

GChemTable Manual
V0.8.0

February 2007 Jean Bréfort jean.brefort@normalesup.org
GNOME Documentation Project

mailto:jean.brefort@normalesup.org
mailto:jean.brefort@normalesup.org
mailto:jean.brefort@normalesup.org
mailto:jean.brefort@normalesup.org


GChemTable manual iv

Contents

1 Getting started 1

1.1 To Start GChemTable . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

1.2 When You Start GChemTable . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

2 Usage 3

2.1 Color Schemes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

2.2 Element Window . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6

3 Charts 9

3.1 Pre-defined Charts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

3.2 Customize Charts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

3.3 User Defined Charts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

3.4 To Copy a Chart . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

3.5 To Export a Chart as an Image . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

3.6 To Print a Chart . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

3.6.1 The page setup dialog. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

4 Support. 18

4.1 To Ask a Question . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

4.2 To Find the Gnome Chemistry Utils on the Web. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

4.3 To Report a Bug . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

5 License 19



GChemTable manual v

List of Figures

1.1 GChemTable window . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

1.2 GChemTable window with an element tip. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

2.1 Physical state color scheme . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

2.2 Family color scheme . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4

2.3 Electronegativity color scheme . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

2.4 Atomic radius color scheme . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

2.5 Block color scheme . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6

2.6 Main Page . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

2.7 Electronic Properties Page . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

2.8 Radii Page . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

2.9 Thermodynamic Properties Page . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

3.1 First ionization energy curve . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

3.2 Chart properties dialog. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

3.3 New empty chart window . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

3.4 New empty chart properties dialog . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

3.5 Adding a plot . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

3.6 Data selection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

3.7 The Page Setup tab. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16

3.8 The Print Scale tab. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17



Abstract

GChemTable is a chemistry elements periodic table application.
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Introduction

The GChemTable application is a chemical elements periodic table application. It provides scientific information on the elements
and multiple table color schemes.
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Chapter 1

Getting started

1.1 To Start GChemTable

You can start GChemTable in the following ways:

Applications list Choose “Periodic table of the elements”. It might be listed either in the Education or Science category.

Command line Type gchemtable, then press Return.

1.2 When You Start GChemTable

When you start GChemTable, the following window is displayed:

Figure 1.1: GChemTable window
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The GChemTable window contains the following elements:

Menubar The menus on the menubar contain all of the commands you need to work with GChemTable.

Periodic table A periodic table of the elements. The colors used for the buttons are conventional colors for the elements. Other
color schemes are also available, as explained later.

When the mouse is moved over an element button, a popup window appears with some data about the element:

Figure 1.2: GChemTable window with an element tip.
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Chapter 2

Usage

2.1 Color Schemes

Several color schemes are available:

No colors All buttons are grey.

Default Conventional colors are used.

Physical state The color of the button depends on the physical state (solid, liquid, or gas) of the element at a given temperature.
This temperature can be changed using the horizontal scale.

Figure 2.1: Physical state color scheme

Elements with a black background indicate that the state is unknown at the given temperature.
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Family The data used are the element family as given in the Blue Obelisk Data Repository.

Figure 2.2: Family color scheme

If a family is selected, only elements of this family will be displayed with their family color used as a background. Other
elements will have a black background.

Electronegativity The data used are the Pauling electronegativity as given in the Blue Obelisk Data Repository. Colors go from
red (lowest electronegativity) to blue (highest electronegativity). If no data is available in the database, the element will
have a black background.

http://www.blueobelisk.org
http://www.blueobelisk.org
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Figure 2.3: Electronegativity color scheme

Atomic radius The data used are the atomic radii as given in the Blue Obelisk Data Repository. Colors go from red (lowest
radius) to blue (largest radius). If no data is available in the database, the element will have a black background.

Figure 2.4: Atomic radius color scheme

http://www.blueobelisk.org
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Block Elements buttons are colored according to the block (s, p, d, or f) to which the element belongs

Figure 2.5: Block color scheme

2.2 Element Window

This window shows the data for an element. To display it, press the corresponding element button in the periodic table. It is
possible to display several element windows at once.

The data are spread over several pages, the following screenshots show the various pages for iron:

Main Page
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Figure 2.6: Main Page

Electronic Properties

Figure 2.7: Electronic Properties Page

Radii
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Figure 2.8: Radii Page

Thermodynamic Properties

Figure 2.9: Thermodynamic Properties Page

When a Show curve button appears on the same line as data, it is possible to display a chart of this data as a function of the
element atomic number by clicking on the button.
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Chapter 3

Charts

3.1 Pre-defined Charts

When you click on the Show curve button in the element window you obtain a chart such as:

Figure 3.1: First ionization energy curve

Some charts can also be displayed by selecting one of the items in Edit → Element charts, except Custom which creates a custom
chart.

Consecutive points are joined by a segment. The absence of a segment means that at least one data point is missing.

Charts can be customized as explained in the next section.

3.2 Customize Charts

To customize a chart, choose File → Properies in the chart window menu. The following dialog pops up:
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Figure 3.2: Chart properties dialog.

The main elements in this dialog are:

The graph hierarchy tree. The graph hierarchy tree (top left) displays the current graph components and their hierarchy. The
hierarchy can be modified using the buttons just below it.

The graph preview. The graph preview (top right) shows the result of the modifications and displays a scaled version of the
graph you will get when you apply the changes.

The Add button. The Add button allows for insertion of new components into the hierarchy. Note that the list of available
components to add depends on the object selected.

The arrow buttons. The arrow buttons can be used to modify the order of child objects of the same parent. These buttons are
only available when ordering makes sense for the currently selected object. If you have, say, two charts in the graph, you
can change the order in the hierarchy, and this will affect the order in which they are displayed.

The Delete button. Clicking the Delete button destroys the selected graph component and all its children. The button is not
available when the component can’t be removed.
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Warning
These deletions can’t be undone, so be careful.

The component properties notebook. The component properties notebook (bottom) shows all the properties you can set for
the current component.

Warning
The window title can’t be changed, so if you customize a pre-defined chart, the title may no longer reflect what is
displayed in the window.
GChemTable does not check the validity of the charts. It is possible add titles and labels not corresponding to the data
actually used, in which case the resulting charts will not make sense.
Some features appearing in the dialog, such as error bars are not currently supported by GChemTable.

3.3 User Defined Charts

A user can create a new empty plot, and then customize it as explained in the previous section.

To create a new empty plot, choose Edit+Element charts → Custom. This will open two new windows: one containing the new
chart, and one containing the chart properties dialog.

Figure 3.3: New empty chart window
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Figure 3.4: New empty chart properties dialog

The graph contains just one empty chart. In most cases, the first thing to do is to add a new plot using the Add button as seen in
next screenshot:
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Figure 3.5: Adding a plot

This adds not only a plot, but also a backplane, the two needed axes, and a data series to the plot.

You can then select the data to use for the new series. Only predefined data vectors can be used. If X values are not selected, an
integer series starting from 0 will be used; that is the atomic number minus one.
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Figure 3.6: Data selection

Further customization is explained in the previous section.

3.4 To Copy a Chart

To copy the chart, choose Edit → Copy and then paste into the target application. Charts will be copied as native graphs to
Abiword or as svg or png data to other applications which support such formats.
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3.5 To Export a Chart as an Image

To export the displayed chart to an image, use File → Save As Image.

Available formats are SVG, EPS, PS, PDF, and formats that support writing in GdkPixbuf.

To choose a format, you can use an appropriate file name extension, or explicitly select a format in the combo box. With the first
method, if GChemTable does not recognize an extension, the exported file will be a SVG file. GChemTable will add an extension
to the file name if needed.

You might change the default width and height of the exported image using the appropriate entries.

Postscript and PDF files can also be produced using the FilePrint... command.

3.6 To Print a Chart

To print the chart, choose File → Print....

File → Preview opens a window with a preview of the printed output.

To tune the printed output, chooseFile → Page setup... as explained below.

3.6.1 The page setup dialog.

The first tab of the dialog concerns the paper and margins setup. Headers and footers are not supported in the version of
GChemTable
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Figure 3.7: The Page Setup tab.

The second tab allows you to choose the scale of the output. With no scaling or scaling at 100%, the output will have the same
size in points as the size in pixels on the screen. If you choose automatic scaling, you can make the output fill the available space
either horizontally, vertically, or both (unchecking both options is equivalent to no scaling).

Printing to more than one page is not supported in this version of GChemTable
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Figure 3.8: The Print Scale tab.



GChemTable manual 18 / 19

Chapter 4

Support.

4.1 To Ask a Question

If you choose Help → Ask a question, your mail client should pop up with a new message to the Gnome Chemistry Utils mailing
list.

Another way to get some help is to connect on the #gchemutils IRC channel on the irc.gimp.net network and ask your question
there (if you are not alone on the channel).

4.2 To Find the Gnome Chemistry Utils on the Web.

If you choose Help → Gnome Chemistry Utils on the web, the default web browser should pop up and display the main page for
the Gnome Chemsitry Utils.

The main page is http://gchemutils.nongnu.org and the project page at Savannah http://savannah.nongnu.org/projects/gchemutils.

4.3 To Report a Bug

To report a bug, you must use the bug page for the Gnome Chemistry Utils at Savannah. You can access it by choosing Help
→ Report Bugs (hopefully you’ll have only one at a time to report).

You can also use a web browser to go to the bug report page address directly. The bug repository is at https://savannah.nongnu.org/-
bugs/?group=gchemutils

mailto:gchemutils-main@nongnu.org
mailto:gchemutils-main@nongnu.org
irc://irc.gimp.net/gchemutils
http://gchemutils.nongnu.org
http://savannah.nongnu.org/projects/gchemutils
https://savannah.nongnu.org/bugs/?group=gchemutils
https://savannah.nongnu.org/bugs/?group=gchemutils
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Chapter 5

License

This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as
published by the Free Software Foundation; either version 3 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied
warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
more details.

A copy of the GNU General Public License is included as an appendix to the GNOME Users Guide. You may also obtain a copy
of the GNU General Public License from the Free Software Foundation by visiting their Web site or by writing to

Free Software Foundation, Inc.
51 Franklin St - Fifth Floor
Boston, MA 02111-1307
USA

ghelp:gpl
http://www.fsf.org
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