
GSpectrum manual i

GSpectrum manual



GSpectrum manual ii

Copyright © 2008-2012 Jean Bréfort

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License
(GFDL), Version 1.3 or any later version published by the Free Software Foundation with no Invariant Sections, no Front-Cover
Texts, and no Back-Cover Texts. You can find a copy of the GFDL at this link or in the file COPYING-DOCS distributed with
this manual.

This manual is part of a collection of GNOME manuals distributed under the GFDL. If you want to distribute this manual
separately from the collection, you can do so by adding a copy of the license to the manual, as described in section 6 of the
license.

Many of the names used by companies to distinguish their products and services are claimed as trademarks. Where those
names appear in any GNOME documentation, and the members of the GNOME Documentation Project are made aware of those
trademarks, then the names are in capital letters or initial capital letters.

DOCUMENT AND MODIFIED VERSIONS OF THE DOCUMENT ARE PROVIDED UNDER THE TERMS OF THE GNU
FREE DOCUMENTATION LICENSE WITH THE FURTHER UNDERSTANDING THAT:

1. DOCUMENT IS PROVIDED ON AN "AS IS" BASIS, WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED
OR IMPLIED, INCLUDING, WITHOUT LIMITATION, WARRANTIES THAT THE DOCUMENT OR MODIFIED
VERSION OF THE DOCUMENT IS FREE OF DEFECTS MERCHANTABLE, FIT FOR A PARTICULAR PURPOSE
OR NON-INFRINGING. THE ENTIRE RISK AS TO THE QUALITY, ACCURACY, AND PERFORMANCE OF THE
DOCUMENT OR MODIFIED VERSION OF THE DOCUMENT IS WITH YOU. SHOULD ANY DOCUMENT OR
MODIFIED VERSION PROVE DEFECTIVE IN ANY RESPECT, YOU (NOT THE INITIAL WRITER, AUTHOR OR
ANY CONTRIBUTOR) ASSUME THE COST OF ANY NECESSARY SERVICING, REPAIR OR CORRECTION. THIS
DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF ANY DOC-
UMENT OR MODIFIED VERSION OF THE DOCUMENT IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS
DISCLAIMER; AND

2. UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER IN TORT (INCLUDING NEGLI-
GENCE), CONTRACT, OR OTHERWISE, SHALL THE AUTHOR, INITIAL WRITER, ANY CONTRIBUTOR, OR
ANY DISTRIBUTOR OF THE DOCUMENT OR MODIFIED VERSION OF THE DOCUMENT, OR ANY SUPPLIER
OF ANY OF SUCH PARTIES, BE LIABLE TO ANY PERSON FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDEN-
TAL, OR CONSEQUENTIAL DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAM-
AGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY
AND ALL OTHER DAMAGES OR LOSSES ARISING OUT OF OR RELATING TO USE OF THE DOCUMENT AND
MODIFIED VERSIONS OF THE DOCUMENT, EVEN IF SUCH PARTY SHALL HAVE BEEN INFORMED OF THE
POSSIBILITY OF SUCH DAMAGES.

Feedback

To report a bug or make a suggestion regarding the GSpectrum application or this manual, go to the GSpectrum home page.

ghelp:fdl
http://savannah.nongnu.org/projects/gchemutils


GSpectrum manual iii

COLLABORATORS

TITLE :

GSpectrum manual

ACTION NAME DATE SIGNATURE

WRITTEN BY Jean Bréfort October 27, 2014

REVISION HISTORY

NUMBER DATE DESCRIPTION NAME

GSpectrum Manual
V0.3

August 2012 Jean Bréfort jean.brefort@normalesup.org
GNOME Documentation Project

GSpectrum Manual
V0.2

April 2010 Jean Bréfort jean.brefort@normalesup.org
GNOME Documentation Project

GSpectrum Manual
V0.1

October 2008 Jean Bréfort jean.brefort@normalesup.org
GNOME Documentation Project

mailto:jean.brefort@normalesup.org
mailto:jean.brefort@normalesup.org
mailto:jean.brefort@normalesup.org


GSpectrum manual iv

Contents

1 Getting started 1

1.1 To Start GSpectrum . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

1.2 When You Start GSpectrum . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

1.3 To Open a File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

1.4 To Open Multiple Files from a Command Line . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

2 Usage 3

2.1 To Customize the spectrum view . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

2.2 Export the Spectrum as an Image . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4

2.3 To Print the Spectrum . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4

2.3.1 The page setup dialog. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

3 Support. 7

3.1 To Ask a Question . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

3.2 To Find the Gnome Chemistry Utils on the Web. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

3.3 To Report a Bug . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

4 License 8



GSpectrum manual v

List of Figures

1.1 GSpectrum document window . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

2.1 GSpectrum default toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

2.2 toolbar for UV-visible spectra . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

2.3 toolbar for IR and Raman spectra . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4

2.4 toolbar for NMR spectra . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4

2.5 toolbar for NMR FID . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4

2.6 The Page Setup tab. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

2.7 The Print Scale tab. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6



Abstract

GSpectrum is a simple spectrum viewer.
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Introduction

The GSpectrum application is a spectrum viewer. It can load a variety of files in the JCAMP-DX format. It can also load NMR
data from the NUTS format.

Supported spectra include UV-visible, IR, Raman, NMR (both spectra and FIDs), and Mass.
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Chapter 1

Getting started

1.1 To Start GSpectrum

You can start GSpectrum in the following ways:

Applications list Choose “Spectrum viewer”. It might be listed either in the Education or Science category.

Command line Type gspectrum, then press Return.

1.2 When You Start GSpectrum

When you start GSpectrum, the following window is displayed:
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Figure 1.1: GSpectrum document window

The GSpectrum window contains the following elements:

Menubar The menus on the menubar contain all of the commands you need to work with files in GSpectrum.

Display area The display area contains the contents of the file that you are displaying and/or editing.

1.3 To Open a File

To open a file, choose File → Open to display the Open File dialog. Select the file that you want to open, then click OK. The file
is displayed in a new GSpectrum document window.

To Open a recently opened file, choose the appropriate entry in File → Open recent

GSpectrum can open files on a remote server.

You can open multiple files in GSpectrum. Each file is opened in it’s own top-level window.

1.4 To Open Multiple Files from a Command Line

You can run GSpectrum from a command line and open a single file or multiple files. To open multiple files from a command
line, type the following command, then press Return:

gspectrum file1 file2 file2 ...

where file1 and others, might be relative, absolute paths or URIs.

When the application starts, a GSpectrum window is created for each file that you specified.
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Chapter 2

Usage

2.1 To Customize the spectrum view

The customization options depend on the spectrum type.

When a spectrum is opened in a new window, the displayed data are those directly read from the file. The abscissa axis might be
inverted in some cases, according to current usage.

In the simplest case, the toolbar looks like:

Figure 2.1: GSpectrum default toolbar

You can set the values of the minimum and maximum displayed coordinates for both axes. These limiting values are constrained
to be within the actual data intervals.

When only a part of the spectrum is displayed, the appropriate slider can be used to scroll through the spectrum view. The
spectrum moves in the same direction as the horizontal slider and to the top when the Y axis slider is moved to the right.

When the spectrum is a UV-Visible spectrum, additional controls are available:

Figure 2.2: toolbar for UV-visible spectra

The abscissa can be switched between wavelength in nanometers and wave number in cm-1 and the axis inverted (high values at
left) or not, and the ordinate can be either absorbance or transmittance.

The toolbar is almost identical for IR spectra. The only difference is that wavelengths are in micrometers instead of nanometers:
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Figure 2.3: toolbar for IR and Raman spectra

The abscissa units available for NMR spectra are ppm and Hz. The integration curve can also been displayed or hidden:

Figure 2.4: toolbar for NMR spectra

An NMR FID can be transformed to the spectrum unless some parameters are missing in the source file:

Figure 2.5: toolbar for NMR FID

2.2 Export the Spectrum as an Image

To export the displayed spectrum to an image, use File → Save As Image.

Available formats are SVG, EPS, PS, PDF, and formats that support writing in GdkPixbuf.

To choose a format, you can use an appropriate file name extension, or explicitly select a format in the combo box. With the first
method, if GSpectrum does not recognize an extension, the exported file will be a SVG file. GSpectrum will add an extension to
the file name if needed.

You might change the default width and height of the exported image using the appropriate entries.

Postscript and PDF files can also be produced using the FilePrint... command.

2.3 To Print the Spectrum

To print a spectrum, choose File → Print....

File → Preview opens a window with a preview of the printed output.

To tune the printed output, chooseFile → Page setup... as explained below.
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2.3.1 The page setup dialog.

The first tab of the dialog concerns the paper and margins setup. Headers and footers are not supported in the version of
GSpectrum

Figure 2.6: The Page Setup tab.

The second tab allows you to choose the scale of the output. With no scaling or scaling at 100%, the output will have the same
size in points as the size in pixels on the screen. If you choose automatic scaling, you can make the output fill the available space
either horizontally, vertically, or both (unchecking both options is equivalent to no scaling).

Printing to more than one page is not supported in this version of GSpectrum
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Figure 2.7: The Print Scale tab.
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Chapter 3

Support.

3.1 To Ask a Question

If you choose Help → Ask a question, your mail client should pop up with a new message to the Gnome Chemistry Utils mailing
list.

Another way to get some help is to connect on the #gchemutils IRC channel on the irc.gimp.net network and ask your question
there (if you are not alone on the channel).

3.2 To Find the Gnome Chemistry Utils on the Web.

If you choose Help → Gnome Chemistry Utils on the web, the default web browser should pop up and display the main page for
the Gnome Chemsitry Utils.

The main page is http://gchemutils.nongnu.org and the project page at Savannah http://savannah.nongnu.org/projects/gchemutils.

3.3 To Report a Bug

To report a bug, you must use the bug page for the Gnome Chemistry Utils at Savannah. You can access it by choosing Help
→ Report Bugs (hopefully you’ll have only one at a time to report).

You can also use a web browser to go to the bug report page address directly. The bug repository is at https://savannah.nongnu.org/-
bugs/?group=gchemutils

mailto:gchemutils-main@nongnu.org
mailto:gchemutils-main@nongnu.org
irc://irc.gimp.net/gchemutils
http://gchemutils.nongnu.org
http://savannah.nongnu.org/projects/gchemutils
https://savannah.nongnu.org/bugs/?group=gchemutils
https://savannah.nongnu.org/bugs/?group=gchemutils
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Chapter 4

License

This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as
published by the Free Software Foundation; either version 3 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied
warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
more details.

A copy of the GNU General Public License is included as an appendix to the GNOME Users Guide. You may also obtain a copy
of the GNU General Public License from the Free Software Foundation by visiting their Web site or by writing to

Free Software Foundation, Inc.
51 Franklin St - Fifth Floor
Boston, MA 02111-1307
USA

ghelp:gpl
http://www.fsf.org
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